Not signed in (Sign In)

Discussion Tag Cloud

Categories

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorAltitude
    • CommentTimeJan 23rd 2014
     
    Posted By: LikiNilsson
    Posted By: secretimbecile^Definitely change the launch to a trim brake (add a block section at the start if you still want a wait)


    The launch is a trim brake and the holding brake is a block section. :/


    Put a small block brake later on in the layout? That might be the problem, but if it's not flashing up with a message, I doubt it :L
    • CommentAuthorEnthraxx
    • CommentTimeJan 23rd 2014
     
    Hello, how can i make switch track like this for a vekoma mine train ? (switch rotate horizontaly )

    http://static.panoramio.com/photos/large/20994826.jpg
    • CommentAuthorReal
    • CommentTimeJan 23rd 2014
     
    You can do an entire launch with 1 brake block segment.
  1.  
    Posted By: EnthraxxHello, how can i make switch track like this for a vekoma mine train ? (switch rotate horizontaly )

    http://static.panoramio.com/photos/large/20994826.jpg


    Double click on the switch piece, and change it to the rotation choice.
    • CommentAuthorEnthraxx
    • CommentTimeJan 23rd 2014
     
    I can only choice "Shift horizontaly" with this type of coaster :/
    •  
      CommentAuthorKingRCT3
    • CommentTimeJan 23rd 2014
     
    ^ That kind of switch doesn't exist (yet?), sadly.

    I wanted to apply custom colors for my trains... But do we have to set all the color one by one? Isn't there any more efficient way? And if I want my second train to look like my first, I have to start over?
    • CommentAuthorPlantoris
    • CommentTimeJan 24th 2014
     
    is there anyway to have the storage section of track, one of the 2 tracks on a storage rack? like an arrow corkscrew.
  2.  

    ^ If I understand your question the answer is no. But you can make two storage sections right after each other and it will function just fine and have the same effect.

  3.  
    ..\..\Users\Austin\Documents\com.nolimitscoaster.nolimits2\newpark 6\sound1.nlvm(16) : error C22: Unknown type: soundTrigger
    ...1 error(s), 0 warning(s)
    ..\..\Users\Austin\Documents\com.nolimitscoaster.nolimits2\newpark 6\soundTrigger1.nlvm(8) : error C59: Method looks like constructor but has wrong name: soundTrigger

    Those are the two errors I get when I try to get a sound to play when the train passes a trigger.

    sound1.nlvm:
    import com.nolimitscoaster.*;

    public class sound1 extends Script {
    private static final String sCoastername = "Coaster 1";
    Coaster cMyCoaster;

    public bool onInit() {
    cMyCoaster = sim.getCoaster(sCoastername);
    TrackTrigger tTrainLeaveStationTrigger = cMyCoaster.getTrackTrigger("Launchsound");

    if(tTrainLeaveStationTrigger == null) {
    System.err.println("Trigger not found");
    return false;
    }

    TrackTriggerListener tTriggerListener = new soundTrigger();
    tTrainLeaveStationTrigger.addTrackTriggerListener(tTriggerListener);

    return true;
    }
    }

    soundtrigger1.nlvm:
    import com.nolimitscoaster.*;
    import nlvm.math3d.*;

    public class soundTrigger1 extends Script implements TrackTriggerListener {
    private static final String sSoundFile = "Launch.ogg";
    StaticSound sSound;

    public soundTrigger() {
    sSound = StaticSound.loadFromFile(sSoundFile, StaticSound.E_ENVMODE_LOCAL);
    if(sSound == null) {
    System.err.println("Sound file not found");
    return;
    }
    sSound.setPosition(new Vector3f(2.7f, 30.0f, 490.0f));
    sSound.setGain(10.0f);
    }

    public void onTrainEntering(TrackTrigger trigger, Train train) {
    sSound.play();
    }

    public void onTrainLeaving(TrackTrigger trigger, Train train) {
    }
    }

    I don't know what I'm doing wrong, I copied it just like in the "LET'S SCRIPT!" thread. I see the "new soundTrigger();" in the first script, but that's how it was presented in the thread. Just the other day I got this to work once; but it didn't keep playing for each train, it only ever played once even after reloading the simulator. Any ideas on what I need to do?
  4.  

    I am experiencing a strange issue. I use c4d to model my models for my coasters, for all I know c4d is game and film making oriented capable of exporting to 3ds. But when I export at first I did not had materials at all, fixed after two hours. Now I have the black shadows bug, meaning all my shadows are just pure black. I know I could bring the model in anim8tor and there fix the shadow issue but that is just again extra work and risks of errors occurring. So anyone any idea how to set the shadow isseu within c4d or something. Or disable the added contrast within no limits.

    • CommentAuthorBlackMamba
    • CommentTimeJan 24th 2014 edited
     
    Had that problem aswell. Instand of Anim8or you can convert your scenery to .nl2sco and then replace the Materials with .nl2mat. If you know Overdrive the materials Ambiente and maybe diffuse aswell and make them lese dark. And then enjoy your now-much-better-looking scenery! Trust me, this is much faster than Anim8or.
  5.  
    ^ Thanks :)
  6.  

    ^Thanks that was the trick! now my models are going to look awesome:D

    •  
      CommentAuthorLing
    • CommentTimeJan 24th 2014
     
    There's a drop-down menu in the colors tab for the coaster where you can choose the stripe. When you do, I think the crosstie color becomes the stripe and the crossties become the same color as the main spine.
  7.  
    Posted By: JoshySqaushy9Does anyone know how to add stripes to the spine of the track like this?


    Coaster properties >colors >spine color scheme >striped
  8.  
    ^ whenever I do that and freeze the coaster I get an error message "Failed to create texture: invalid call" any fix for this? :/
    •  
      CommentAuthorride_op
    • CommentTimeJan 24th 2014
     
    If your laptop has an nVidia or ATI graphics card you should ensure that the drivers are configured to run NoLimits 2. Intel integrated cards are getting this problem and we are testing a fix for a maintenance update.

    -Ride_Op
    • CommentAuthorMGrides
    • CommentTimeJan 25th 2014 edited
     
    Hello =)
    I have a problem with importing .3ds:

    I made a 1x1 meters cube with sketchup. Exportetd it as .obj and imported it in wings3D. Than i exported it as .3ds ... (yes i know, not the best way, but i don´t have SketchUp Pro).
    If i add the cube in NL2 .. it´s very small.
    If i export from Blender or Anim8tor .. it´s the same issue.
    BUT! -> i sent the cube to another friend and he imported it into NL2.
    Well,.. he don´t have the problem. In his NL2 the cube is accurate 1x1 meters! Now i´m confused.. why isn´t it correct in my NL2 (Pro)? I set the scale in NL to metric, so no translation problem here.. what i´m doing wrong?

    Edit: The only thing that works -> if i make an object with the "good old" Object Creator.. the .3ds is fine in NL2.

    Have a nice Weekend @all ;)
    • CommentAuthornannerdw
    • CommentTimeJan 25th 2014
     
    I had to scale objects in Blender by (1/.0254) in order to import them at the proper scale.
  9.  
    Is there a shortcut to save while using the editor? Sounds very simple, like ctrl+S, but it doesn't seem to do it. If there was I could use an external application to perform the keyboard shortcut every so often which would act as an auto-saver.
  10.  
    Posted By: nannerdwI had to scale objects in Blender by (1/.0254) in order to import them at the proper scale.


    That's almost the same as me, but I've found x39.4 to be absolutely precise for everything I've done so far.
    •  
      CommentAuthorJAMMYD778
    • CommentTimeJan 25th 2014
     
    Could anyone help me script a fog effect to trigger as a train passes a trigger point, however I only want it to be active for the set ACTIVE time and the rest of the time be inactive. I've been reworking scripts for the past two days and can't make it work. Many Thanks :)
    • CommentAuthorcaptfido87
    • CommentTimeJan 25th 2014
     
    For some reason I can't get the lift stairs to appear on a 2 row ptc wood coaster. I have the style setting for that piece checked for handrails and nothing is working. Any ideas?
    • CommentAuthorsprog
    • CommentTimeJan 26th 2014
     
    You need to generate the handrails and catwalks through the auto-support generator, under "supports"
    • CommentAuthorReal
    • CommentTimeJan 26th 2014
     
    For everyone with the Pro...the ability to overlay images is FANTASTIC. Recreations...so much quicker now.
    • CommentAuthorElvenage
    • CommentTimeJan 26th 2014
     
    Wait, I can do that with standard version.

    Am I not supposed to be able to?
  11.  
    Why after exporting an element from newton to NL2 some inversions such as cobra roll and roll over get some bumping vertices? I mean, at the middle of them the track gets crooked

    PS.: This didn't used to happen in NL1
    • CommentAuthorReal
    • CommentTimeJan 26th 2014
     
    Ah, I read "Transparent background screenshots" as something different.

    Xpress, stop being a dummy!
    •  
      CommentAuthorrcrider4
    • CommentTimeJan 26th 2014
     
    Because Newton isn't optimized for NL2. Use the latest version of FVD++ instead if you can.
    • CommentAuthorTOGO Fan
    • CommentTimeJan 26th 2014
     
    That is really good that newton does not work for NL2. Less newtony coasters!
    • CommentAuthorElvenage
    • CommentTimeJan 26th 2014
     
    Until Entropy crawls out from nowhere to release newton3 for nl2, lol.
    •  
      CommentAuthorbaadrix
    • CommentTimeJan 26th 2014 edited
     
    ^Who knows? ;)

    I've got two questions:
    1.) I made an underground tunnel and added some lights within the tunnel. Is there any way to prevent the lights from appearing on the ground or even on a nearby (aboveground) track other than reducing the length of the light cone/beam?

    2.) Is it possible to have a sharp divsion between different ground textures (like for paths)?
    • CommentAuthorole
    • CommentTimeJan 26th 2014
     
    @baadrix:

    If your light is a spot light, you can enable shadows. Shadows should prevent the light from affecting objects behind shadow casters (the tunnel), note that shadows will cause a bigger performance hit. You may also try to decrease the light range and compensate the stronger attenuation with an intensity above 1.

    No, it is not possible to have a sharp division. The terrain textures are not very usefull for creating paths.
  12.  
    Is there away to make a complete circuit Sky loop style coaster have the gentle second pass option or does that have to be scripted
    • CommentAuthoraustinjb555
    • CommentTimeJan 27th 2014 edited
     
    I'm trying to figure a way to make the train delay dispatch after the dispatch button has been pressed. I'm pretty sure this requires the scripting block mode, but is there a different way to do it? I'm trying to make a Premier LIM launched coaster a la Backlot Stunt Coaster or Flight of Fear. To add the sound of the LIM's I am thinking about just putting the trigger before the station and putting blank space at the beginning of the audio file and making it wait the right amount of time, but then it would be awkward if E-Stop were pressed and it played that noise. So I'm trying to tie it into the dispatch!
    • CommentAuthorYPOC
    • CommentTimeJan 27th 2014
     
    ^ I have only been able to do this in scripted mode.
    • CommentAuthor8baan
    • CommentTimeJan 27th 2014
     
    Hi guys,

    I would like to ask you a question.
    Can someone make a tutorial to get music into a station with scripting?
    I tried but it won't work.

    Hope you guys can help me further.
    • CommentAuthorEnthraxx
    • CommentTimeJan 27th 2014
     
    I had a problem, i want to put fog but i can't found it -_-" I go to "Element/Add element/Library/Scene object/Demo object" But there is nothing ... The only element i can put are special part for coaster (loop...)
    •  
      CommentAuthorrcrider4
    • CommentTimeJan 27th 2014
     
    It's not under Element, it is under Scenery. Go to the scenery tab and click "Choose..." and then go to the Library tab in the pop up. Then go in the Demo Objects folder and scroll to the bottom. There you will find something called Volume Fog.
    •  
      CommentAuthorAussieMine
    • CommentTimeJan 27th 2014
     
    I had this weird glitch happen to me just now while checking out my latest coaster I'm working on. (It's sort of a teaser I guess, but it's more of a bug report)

    <a href="http://s843.photobucket.com/user/AussieMine/media/asd_zpsc986fc4f.png.html" target="_blank"><img src="http://i843.photobucket.com/albums/zz356/AussieMine/asd_zpsc986fc4f.png" border="0" alt=" photo asd_zpsc986fc4f.png"/></a>
    • CommentAuthorWildRoller
    • CommentTimeJan 27th 2014
     
    I actually had that issue pop as well on a coaster I was working on, There was also a spot on the transfer track behind the station that I couldn't put railing on, don't know if those two things are related.

    I ended up saving the track as an element and starting over on a new park to get it to go away.
    •  
      CommentAuthorAussieMine
    • CommentTimeJan 28th 2014
     
    I just put scenery over it, and it's not noticeable unless you actually look
    •  
      CommentAuthorPhyter
    • CommentTimeJan 28th 2014
     
    AussieMine, if you have not done so yet, please go to "Home -> Info -> Check For Updates" and update to the latest version. We just fixed a very similar bug.
  13.  
    Hi guys,

    Is there a way to disable water at all?! I can't find a way. I want to lower the terrain because my track is basically touching the ground so I need to lower the terrain under it to place supports.
    •  
      CommentAuthorL Bosch
    • CommentTimeJan 29th 2014
     
    Raise the terrain level and your track and supports, then you have more space underneath before water will appear.
    • CommentAuthorhomestea
    • CommentTimeJan 29th 2014
     
    It would be nice is there was a mode or way to drag vertex points in only the z direction (height) while in perspective. It would be very helpful when working on recreations that are using an overlay. I like adjusting my track height in perspective view but I end up having to go to
    The top view to correct any x and y accidental movement due to
    The perspective angle..... Is there any way to do this? Am
    I just missing something?
    •  
      CommentAuthorKingRCT3
    • CommentTimeJan 29th 2014 edited
     
    Try using the "Page up/ Page down" keys.
  14.  
    Posted By: L BoschRaise the terrain level and your track and supports, then you have more space underneath before water will appear.


    Unfortunately, that's not an option as there are lots of hills that interact with the coaster. I've pretty much finished all the terrain and it took a long time! I dont want to start again for the sake of a few supports.
    •  
      CommentAuthorI305Evan
    • CommentTimeJan 30th 2014
     
    In manual block mode, is there (or can there) be a way to add a reverse button to any block that has friction wheels? Right now, only the transfer track can back up.
  15.  
    Does anyone know how to transfer NL2 on a USB a usb stick? I have a new computer but the internet isn't set up yet but I still want to test NL on it, I have my user id and key but when I try to run it a error message comes up, something about a missing file???