Not signed in (Sign In)

Discussion Tag Cloud

Categories

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorole
    • CommentTimeJan 12th 2017
     


    Too much fun: http://faketrumptweet.com
    •  
      CommentAuthorFüchschen
    • CommentTimeJan 12th 2017 edited
     
    Posted By: JL NoLimitsIt looks like the bloom effect :D


    Yeah, thanks, but im not able to find the options for the bloom effect in the setup menu of NL2.

    I thought, this was the view panel:

    The Bloom effect can be turned off in the view panel

    There is not even something close to "view panel".
    where do i have to look? :D
    • CommentAuthoriCoaster44
    • CommentTimeJan 12th 2017 edited
     
    In the simulation, it's the window where you can change the FOV, DoF and such.
    •  
      CommentAuthorjpaufsc
    • CommentTimeJan 12th 2017
     
    ^^ Hit F7 when in the sim.
    •  
      CommentAuthorFüchschen
    • CommentTimeJan 12th 2017 edited
     
    Wow. Didn't know that this exist :D *lol*

    thank you very much :3

    Edit:
    That explains, how most of those "cinematic screenshots" were made.
    •  
      CommentAuthorride_op
    • CommentTimeJan 12th 2017
     
    I'M NOT PAYING FOR ANYONE'S WALL!

    lol

    -Ride_Op
    •  
      CommentAuthorBirdNerd
    • CommentTimeJan 12th 2017
     
    After being inactive from the forums for quite a long time now due to many busy things going on in my life, I just recently got NL 2.5 and it is beyond fantastic! I enjoy adjusting the settings for the new lighting engine to make everything more realistic and stand out much better than before! But before I go too much into detail about the good things, there are two major things that have been annoying me for months, and I really want to see them implemented in a future version sometime soon.

    1: Please make all dragging elements (beam nodes, flanges, rail connectors, type separators, style separators, roll points, etc.) snappable according to the snap value! In NL 1.8, I remember dragging the rail connectors to exactly the places I wanted them with whatever snap value I chose. It made supporting so much easier, and I felt like I could actually make supports faster rather than trying to guess where it was in relation to the grid size.

    2: Please make a built-in terrain filter like the one present in NL 1.8. In the previous version, I was able to create all sorts of terrain features like in five minutes or less. Nowadays, I just leave my terrain flat for now in NL 2.5 because I still cannot make hills with exact slopes throughout the elevation range so it looks neat. In RCT 3, the terrain engine was pretty much perfect, and it was very easy to create whatever I wanted.

    Lastly, here are two pictures of Intamin-style box supports from my past Superman recreation. You can clearly see that the frozen coaster result looks very bad, and if only those beam-nodes were snapped properly, then everything would look great!

     photo Fail2_zpsdtltt5kf.jpg

     photo Fail1_zpsofxul1ia.jpg

    I am sorry for how critical I am being at the moment, but I am just very picky about this software I guess!
  1.  
    For the clipping just ad a bit of extra lenght to the beam like 0.001 or something ;)
    •  
      CommentAuthorHZGarfield
    • CommentTimeJan 13th 2017
     
    Another little request about new features in 2.5 : Add some "custom" sound file link input for station gate / entrance gate etc rather than simply add them and uneditiable (Most of modern coaster will not hiss so loud when passenger gate opens)
    •  
      CommentAuthorbestdani
    • CommentTimeJan 13th 2017
     
    \o/
    • CommentAuthorMrRC
    • CommentTimeJan 14th 2017
     
    I don't have that.
    •  
      CommentAuthorride_op
    • CommentTimeJan 14th 2017
     
    You have to have the Steam version and opt in to the Beta branch to get that. We're testing it out.

    -Ride_Op
    •  
      CommentAuthorHZGarfield
    • CommentTimeJan 14th 2017
     
    ^^^ That feature is useful (Didn't know if unsubcrived park will be deleted? )
    •  
      CommentAuthorzampano
    • CommentTimeJan 15th 2017
     
    As I'm working on a release for Three Evils, I've stumbled across some weird lighting behavior. I've got some flickering shadow/light patches on my water that randomly appears while the water or camera is moving and stays still when in pause mode with a static viewing angle. At first I could recreate it in other parks as well, I then increased the sun shaft quality from 2 to 4 (max) and now it's not occuring with the standard environment and I think daytime environments in general.

    It looks like this (with and without my fog object):


    the fog-object is one-sided and does not cast shadows if that helps.
  2.  
    I have that exact problem in Oakvale. All the animated flags constantly flicker with that same light patch thing.
    • CommentAuthornannerdw
    • CommentTimeJan 16th 2017 edited
     
    I got a similar flickering, too, zampano. It wasn't on the water, though, just on one large object that had the texture in the dae file itself. Overriding the material fixed it for me.
    • CommentAuthorole
    • CommentTimeJan 16th 2017 edited
     
    If you do not like how the shadow and SSAO look, you can turn them off in the setup. Or even better: Stop using NL2.

    That is the way these effects look. Live with it or turn them off.

    I very often feel that my customers are way more nitpicking and complain more about every small issue and detail than typical customers of other games. It is frustrating.
    • CommentAuthornannerdw
    • CommentTimeJan 16th 2017
     
    The SSAO looks much better when I increase "Antialiasing - Transparency" to its max value in the Nvidia Control Panel.
  3.  
    yeah i found that since the update, if you force the AA through the nvidia control panel it looks a fair bit smoother, don't seem to have lost any performance either, although i do have a somewhat overkill pc now. I assume a similar thing can be done for amd cards as well.
    • CommentAuthornannerdw
    • CommentTimeJan 16th 2017
     
    Yeah, I wouldn't recommend the FXAA, though. It makes the text more difficult to read.
  4.  
    I'm not the only one who noticed the new vanilla sounds, such as the brake release. Much less annoying; the new update also lags the hell out of my machine
    •  
      CommentAuthorride_op
    • CommentTimeJan 17th 2017
     
    The new update turned on many advanced graphics features by default. If your machine is struggling, we recommend turning off Screen Space Ambient Occlusion, Bloom, and Shadows if needed.

    -Ride_Op
    • CommentAuthorPhysical
    • CommentTimeJan 19th 2017 edited
     
    Despite all the complainers, NL2 is honestly the most comprehensive and detailed coaster program that is simultaneously easily accessible and incredibly in depth out there. (Not to mention the most recent update made the program look absolutely fantastic! I know most people don't have a computer capable of maxxing it out, but for those of us that do... WOW it is seriously impressive)

    Serious props to all that work on this fantastic program! Coaster nerds are notoriously complain-ey, I'm sorry that the dev team has to deal with us :p
    •  
      CommentAuthorelement 115
    • CommentTimeJan 20th 2017 edited
     
    I have a strange performance issue that seems to only occur for me.
    https://gyazo.com/3f8d7426fc354f69099d86de1069f1bb
    As you can see, this very detailed park scene is running at a solid 60 fps, (its actually over 100 fps with v sync turned off), i have also run the park at night with 100's of lights and it also performs fantastically well thanks to the new update.
    However, if i render the sun in my env, (or use dynamic sky) and look directly at the sun i get a massive performance drop:
    https://gyazo.com/f23841413772977126e52b6fd228adfe
    This shot is not even hitting 40 fps while looking at the sun, i get the same result in a completely empty park too... If i looked anywhere else i would get over 600+ fps.
    Ive talked to a few other users and they have no performance drop so im assuming its something unique to my pc.

    Im running an Intel i7 6700k skylake cpu, gtx 1080 8gb graphics card and 32 gb of ram. so a pretty overkill system, if anyone has any ideas what might be causing it or suggestions for fixes please let me know.

    UPDATE: ive just loaded up an empty park, turned off all advanced effects, and put all the sliders to minimum, same issue... shall i try reinstalling nl2??
    •  
      CommentAuthorride_op
    • CommentTimeJan 20th 2017
     
    Does turning off Bloom improve things? Try disabling it and report it to techsupport@nolimitscoaster.de

    -Ride_Op
  5.  
    https://gyazo.com/5e30e22807806fb850fd43e9ab3c2536
    Yep every effect has been turned off, ill report it to support now.
  6.  
    So I have one park that will never go to night mode. In have it set for 5 minutes so it should cycle through but one of my parks does. I load other parks it works like it should. This was even before the 2.5 update. Any ideas on why that would be? There is lots scene objects in the park if that is useful at all.

    Thanks
    •  
      CommentAuthorride_op
    • CommentTimeJan 20th 2017
     
    There is a setting conflict between your setting for the day/night cycle and what may be set in that park directly.

    -Ride_Op
  7.  
    ^Where in the park would I find those settings?
    • CommentAuthorgekkedave
    • CommentTimeJan 21st 2017 edited
     
    I hope somebody can help. Since i did the 2.5.2 update big parts of my terrain are disappeared. Is this a bug or is there something i can do? It's only when i freezed my coaster and also in the simulator.

    (freezed)


    (unfreezed - terrain is ok)


    Made images visible - Staff
    •  
      CommentAuthorride_op
    • CommentTimeJan 21st 2017
     
    Working on that one. Please send the park in to techsupport@nolimitscoaster.de

    -Ride_Op
  8.  
    Is it possible to add a setting to the .nl2cso settings that can make the inbuilt occluders ignore this object? It might be helpful for some objects such as the flag pack, which currently phase in and out in some areas

    https://gyazo.com/9e139b465226ad39146316b9958f6da6
    •  
      CommentAuthorKingRCT3
    • CommentTimeJan 21st 2017
     
    Posted By: UtahCoasterRider^Where in the park would I find those settings?


    Have you looked into Park -> Environment... -> Override Default Date/Time
    You might have that checked.
    •  
      CommentAuthorjpaufsc
    • CommentTimeJan 21st 2017
     
    While you're here Ride_Op, is it at all possible to use any of the materials located inside the data archives in the NL2 root folder? I was inspecting the new chain link fence and the transparent fence texture would come in handy for some of my scenery objects.
    •  
      CommentAuthorbestdani
    • CommentTimeJan 22nd 2017 edited
     
    Although I'm not ride_op:
    You would just have to replace the material with the internal material path and ensure that the UV map is compatible on your object, you can even reference to the texture in your own material using the internal path:
    •  
      CommentAuthorFüchschen
    • CommentTimeJan 22nd 2017 edited
     
    i get an error and i dont have any clue, what NL2 needs:

    [...]\LightRig\Script: File not found
    Failed file: "[...]\LightRig\Script"


    I think, NL2 looks for a file in the folder "Script". But i never told 3ds max to export something there.
    3Ds max always puts textures in a folder with the same name as the 3d model.

    example:
    lightRig_mesh.dae
    lightRig_Mesh/texture1.jpg

    Not sure where the script comes from. This model dosn't even use nl2script or nlvm right now (because always setup all materials befor starting to script anything).

    the only warnings i get are those:
    While reading or writing a file the following notifications have been raised.
    -Warning: 'Null' type not supported by COLLADA. Only the transform data of node: 'Y_ROTOR' will be saved.
    -Warning: 'Null' type not supported by COLLADA. Only the transform data of node: 'X_ROTOR' will be saved.

    And this is totally fine, because i only need the transform data of those.

    I didnt change the export settings or so. Worked fine two weeks ago.


    EDIT:
    Found the cause of the problem.

    white-spaces.

    If the park is called: "My Park" it causes problems for the DAE Exporter...
    I think i'll remove any textures from now on and only use nl2mat files.
    •  
      CommentAuthorjpaufsc
    • CommentTimeJan 22nd 2017
     
    @bestdani: I don't know why it didn't occur to me to try that, but it did the trick. Thanks for the tip!
    • CommentAuthoriHack97
    • CommentTimeJan 22nd 2017
     
    hey guys, is it possible to make a fluorescent shiny nl2mat that reacts with blacklights (purple/blueish light)
    •  
      CommentAuthorbestdani
    • CommentTimeJan 22nd 2017
     
    Adding some emission to the material of the fluorescenting objects should be trick. Maybe control it with one of the entity colors if the object should be used in a blacklight and non blacklight environment.
  9.  
    Found a small bug with the SSAO, not sure if it was brought up or not. It seems to suddenly stop during sunset/sunrise


    Video Example
    • CommentAuthorGigaG
    • CommentTimeJan 26th 2017
     

    NL2 was just updated to v2.5.0.4

    The biggest direct change is that there is a new virtual tunnel segment without sound reverb, and there are also a series of bugfixes and settings tweaks to go with it.

    •  
      CommentAuthorbestdani
    • CommentTimeJan 27th 2017
     
    Posted By: GigaGvirtual tunnel segment without sound reverb

    I think that this is very useful in some occasions.
    •  
      CommentAuthorKingRCT3
    • CommentTimeJan 27th 2017
     


    When did the Lock On Terrain feature was added? It's sooooo useful, thanks a ton!!
    • CommentAuthorJetPulse
    • CommentTimeJan 27th 2017
     
    I think that's been there the whole time. Been used for trees and the like.
    • CommentAuthorTheBeatles
    • CommentTimeJan 27th 2017
     
    The feature has been in the nl2sco editor for as long as I can remember, but it was added to the main scenery properties panel in NL2.5
    •  
      CommentAuthorKingRCT3
    • CommentTimeJan 27th 2017
     
    Yeah I know it has been there from the beginning, but you had to make a new SCO each time. Now you can individually check and uncheck that directly in the editor, which is great.
  10.  
    Ever since the new update, the complete white on white environment looks like this now. The terrain wont go plain white anymore?
    •  
      CommentAuthorride_op
    • CommentTimeJan 27th 2017
     
    Try turning off Bloom when using the White Environment. Likely the sky is blooming and the ground is not.

    -Ride_Op
  11.  
    Unfortunately that doens't do the trick. checking the bloom option just makes the transition from terrain to environment less seamless
  12.  
    Does anyone have a good Color code for a wood coaster? Thinking Southern Yellow Pine.

    Thanks