Not signed in (Sign In)

Discussion Tag Cloud

Categories

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorRickPlays
    • CommentTimeJan 18th 2017 edited
     
    Hey guys,
    I have some problems with my videos on Youtube because they have lots of artifacts. However, the normal video file on my computer does not have these artifacts. Has anyone an idea how I should encode the videos?

    If you don't know what I meen, here is an example of one of my Videos: Video

    My render settings are:

    Bild

    Hope someone can help me.
    •  
      CommentAuthorYedrimas
    • CommentTimeJan 18th 2017
     
    Unfortunately, you can't do really much on that... Youtube reduces the amount of information on each frames (video).
    •  
      CommentAuthorFüchschen
    • CommentTimeJan 18th 2017 edited
     
    Does your software have a "deblocking-filter"?
    Also set-up a maximum bit-rate.
    mine is: 135.000.000 (135mb/s).
    and the average is 50.000.000 (50mb/s).

    Video codec: YUV (cant change it for mp4 :/ )

    Here is another example, but i think it works only for videos without much movement (like news v-logs).
    https://www.youtube.com/watch?v=mJB0-0YW_SQ

    never saw any artifacts on my video.


    You could render a unlisted/private test video and compare them.
    With lots of movemet. For example: one of the flatrides.
    I can only export 720/30 videos with nolimits, so i dont know, how this would work for 1080/60

    Then you can tweak the settings until it looks good enough.

    Edit
    older video without correct settings: click
    more recent video with correct settings: click

    there is certainly a difference.
    •  
      CommentAuthorRickPlays
    • CommentTimeJan 19th 2017
     
    ^ I did a other rendering with the highest bitrate from Premiere (300Mbit/s). Unfortunately, there where no big differents between 50Mbit/s and 300Mbit/s.

    I will try some other settings particularly from the video you send and your render settings.
    •  
      CommentAuthorRickPlays
    • CommentTimeJan 22nd 2017
     
    So, after a few days, I tried some different render settings. Once with the render settings from Füchschen and once with the settings from this video: Click me

    Here are my to renderings:
    Low Mbit/s (8Mbit/s): Click me
    High Mbit/s (300MBit/s): Click me

    In my eyes, I see no difference. Both Videos have the artefacts. So I think I have to life with it.
    If someone has some other ideas to fix this problem, let me know :D
  1.  

    YouTube compresses your video further as you upload it. (That part that says "processing" - that's it doing the damage.) It's annoying, but with YouTube being the largest video site on the planet, what can ya do. They have to store sooo much video, and it has to stream quickly. So they compress the hell out of anything that goes up there.

    I believe they have their own standards set lower than what most would consider standard for each 1080p/720p quality setting. Therefore I've seen many tutorials claim to set your bitrate to two-pass, with 12 and 8 Mbps set for each pass. The claimed reason is that YouTube in fact uses those settings, and that if you do this correctly first, YouTube won't bother compressing your video, so you'll actually see maintain a bit more quality. The idea is that your video editor of choice does a better job than YouTube's catch-all blunt instrument, and you should see a very slight improvement.

    Have I seen this "added quality" using those settings? No, not at all really. I honestly might just go back to exporting to higher bitrates just for my own sake of keeping these videos on file in high quality. YouTube is gonna dish out damage no matter what - there's no going around that. They'll mash together your blacks and pixelate your whole screen when a bunch of trees fly past (as demonstrated in Yedrimas' link).

    I should also mention that if you're getting horribly dark footage (especially for nighttime coasters), try changing your compositing gamma in Project Properties. For NoLimits 2, I think it's actually best to use "32-bit video levels" instead of "32-bit full range" if I remember correctly. (I may need to double check on that, but you get the idea that you need to change to one of those.) If you see your preview get brighter, you chose the right one, and if it gets darker, then go back to what you had.

    I hope some of that helps!

    •  
      CommentAuthorRickPlays
    • CommentTimeJan 24th 2017
     
    ^Yea, thanks for that.